Anabolics
Search More Than 6,000,000 Posts
Results 1 to 4 of 4
  1. #1
    buff999 is offline New Member
    Join Date
    Jan 2004
    Posts
    34

    after injection issue

    did 1cc of prop in my delt on friday night....i have a feeling a did it a bit too fast...today(sunday) the delt is sore and red.....theres no lump, it feels tight though...is this just what I have been hearing that if you go too fast, the oil doesn't move fast enough, so it just sits? or is it something to do with a high content of BA?....

    first cycle as well....second shot....first was in my quad...pretty sore but no redness or anything...

    thanks

  2. #2
    stocky121's Avatar
    stocky121 is offline VET~ Recognized Staff Winner - $100
    Join Date
    Sep 2004
    Location
    england/north east
    Posts
    10,011
    i woulden't be to worried at the momen't if it persits's (spelling) for say over a week i would start to get worried it will hurt for a few day's after injection but for every CC that you inject give a minute to inject it. I hope that help's you out

  3. #3
    Join Date
    Oct 2004
    Location
    Arkansas
    Posts
    854
    just started to cycle in my prop and YES it burns like hell, havnt had any redness, but just 2 injections into the prop of it, the sus has prop in it, and itburned for a day or so after the injections

    Alex

  4. #4
    buff999 is offline New Member
    Join Date
    Jan 2004
    Posts
    34
    thanks guys....yeah i think i just put it in too quickly..i have been reading that the oil doesn't dissapate(correct word?) properly throughout the muscle it kinda suspends and takes a few days to disperse

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •