Anabolics
Search More Than 6,000,000 Posts
Results 1 to 7 of 7
  1. #1
    supersteve Guest

    Strange blood test results

    I got a blood test on the day of my second tren shot.
    I've been taking hgh 4iu for 10 weeks, finished an igf1-lr3 cycle 2 weeks ago and have been taking letro for the past 6 months at 0.5-1mg a day.
    I am VERY sensitive to estrogen (had gyno cut out 6 weeks ago which was there from puberty) which is why I have been taking letro and also why I chose to go against conventional wisdom and not use test with my tren cycle - not to mention that I have no libido from letro anyways (can get it up when i need to but no sexual desire otherwise).

    So anyways, my free testosterone (after 2 tren shots of 50mg) was 13.6 pmol/L (normal range 34.5-98.0 pmol/L). Which I thought was fine considering hooker said deca can shut u down completely after just 100mg ... and because my nuts were actually looking atrophied already. But my Oest 17-beta (estrogen) was 915 pmol/L!!!!!! (normal range is 70-280 pmol/L).

    How is that possible? The only thing I can really think of is that I cranked open a new bottle of letro 2 weeks ago and that perhaps it was a dud and i've got massive rebound. But i'm showing no real signs of high estrogen and have still been getting all the typical letro sides.

    My last blood test, when I got e2 checked (estradiol), it was very low because of letro. So unless Oest 17-beta is total estrogen rather than just e2? But I think it means the same thing.
    Or perhaps the tren caused a huge reduction in SHBG and therefore estrogen rose significantly?

    I'm baffled by this. Is there any clinical explanation for this? Hooker?

  2. #2
    supersteve Guest
    Okay I just read this:

    "Finaplix was the last remaining pure trenbolone acetate, however it too had now been discontinued and replaced with Revalor, trenbolone acetate with a small amount of estradiol, an estrogen"

    Is it possible this is what i'm using? I got the tren ace powder from a source in china and homebrewed it myself.

  3. #3
    Slic4788 is offline Associate Member
    Join Date
    Jan 2005
    Posts
    275
    I don't know man, I read your results in the gh forums too. Seems pretty odd. I don't think that's possible with just 2 shots of tren . And you aren't getting any gyno or high e2 sides.

    I would think it's the lab test they screwed up on. Sometimes it happens. You did say there were no asteriks by it, isn't that wierd?

  4. #4
    supersteve Guest
    Quote Originally Posted by Slic4788
    I don't know man, I read your results in the gh forums too. Seems pretty odd. I don't think that's possible with just 2 shots of tren . And you aren't getting any gyno or high e2 sides.

    I would think it's the lab test they screwed up on. Sometimes it happens. You did say there were no asteriks by it, isn't that wierd?
    Yeh normally it is in bold and with an asterix. Although i've had a value outside the normal range not have this once before as well, so i dont know.
    I'm a little worried that perhaps my supplier did give me the tren with estrogen? Perhaps if there are any mods that order tren ace powder from china I could do a source check.

    If this is the case im also guessing that letro would do nothing as it only stops the conversion of test to estrogen but doesn't actually lower circulating estrogen?

  5. #5
    supersteve Guest
    Guys, is there an easy way of checking whether a brewed solution has estrogen in it? I've got a feeling my tren ace powder might also have estradiol as well.

    I know with GH you can spray a bit onto a pregnancy kit and it will tell you if it's HCG or not, is there something similar for detecting estrogen?

    Thanks.

  6. #6
    Bryan2's Avatar
    Bryan2 is offline Supplement Guru
    Join Date
    Jun 2004
    Posts
    3,746
    the letro is bunk or you are not shaking the bottle up each time before use

  7. #7
    supersteve Guest
    Quote Originally Posted by Bryan2
    the letro is bunk or you are not shaking the bottle up each time before use
    Thing is, i've never had to shake the bottle before and it's worked fine. And this is the same letro i've been getting for the past 9 months. Perhaps a bad batch.

    Would still like to know for sure it's not the tren

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •