Anabolics
Search More Than 6,000,000 Posts
Results 1 to 7 of 7

Thread: clen question?

  1. #1
    ili
    ili is offline New Member
    Join Date
    Sep 2005
    Posts
    30

    Question clen question?


    Hey I was wondering if anyone has ever had a kind of pain in testicles(like you've been kicked in the balls)feeling while taking clen ,did about 5 days,tolerated the shakes headache symptoms,kept doses within tolerance,but had to stop cause of the swollen feelings in testicles,any input would be appreciated.Should I stop for a bit try 2 days on 2 days off instead of trying 2 weeks approach.What could it be?

    Thanks

  2. #2
    MBaraso's Avatar
    MBaraso is offline Retired Mod
    Join Date
    Oct 2001
    Location
    Somewhere
    Posts
    7,611
    Are u taking anything else? Specificly AS?

  3. #3
    ili
    ili is offline New Member
    Join Date
    Sep 2005
    Posts
    30
    no I'm not the only thing I was taking was an no2 product,also taurine and potassium,weird isn't it?

  4. #4
    Pimp_C's Avatar
    Pimp_C is offline Associate Member
    Join Date
    Jul 2005
    Posts
    189
    are u currently on a cycle, if so, that is probably what is causing this, not the clen

  5. #5
    ili
    ili is offline New Member
    Join Date
    Sep 2005
    Posts
    30
    no i'm not on a cycle, it's been two days since i've stopped the clen and am feeling better,I talked to a friend and he's heard someone else have the same feeling,wonder why?guess everybody has different reactions.I do appreciate your inputs.This site is awsome.lots of info,but I still wonder what caused the feeling in testicles?will try it again in a week to see(hopefully it goes better)

    Thanks guys

  6. #6
    Papi93's Avatar
    Papi93 is offline AR VET
    Join Date
    Jul 2005
    Posts
    12,336
    I have used AR's liquid clen and have had no testicular discomfort. I know you said that you are not taking AAS right now but are you currently off-cycle? If not, I wish you good luck on your second try!

  7. #7
    ili
    ili is offline New Member
    Join Date
    Sep 2005
    Posts
    30
    I actually havn't used any AS ever,thinking of trying it,been doing lots of research first,but hey thanks,like you said hope I have better luck next try.
    Take care guys

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •