Anabolics
Search More Than 6,000,000 Posts
Results 1 to 7 of 7
  1. #1
    Buschlightcan's Avatar
    Buschlightcan is offline Associate Member
    Join Date
    Oct 2002
    Location
    Southern California
    Posts
    378

    Homemade Fina Help

    I just recently made a 4g batch. I followed the directions from gotfina.com exactly. I prolly put it in boiling water 4-6 times to get rid of bacteria. The only problem is it doesnt look like the batches posted in the pictures section of hommade fina. My fina is defidently gold but it is not transparent like everyone elses. It like a solid non transparent gold fluid. Should i be worried about it? Has anyone ever made fina that wasnt transparent before? Please help!

  2. #2
    painintheazz's Avatar
    painintheazz is offline Anabolic Member
    Join Date
    Dec 2002
    Location
    Boston area
    Posts
    3,352
    The batch that I just mad came out a little cloudy. It is still working fine for me. I think it is due to the extra heating that you did. I heated mine a little extra to make sure everything was dissolved nicely. IMO I think you are fine. You did use a filter, right????? I will leave it up to a more knowledgable fina bro to give a final answer.

    Pain

  3. #3
    Andy is offline Associate Member
    Join Date
    Nov 2001
    Location
    Knoxville, TN
    Posts
    188
    Hey im strictly novice here on this one cuz I am makin my first batch this week.
    But I have read a lot of posts where Fina was said to be cloudy after heating it, and that it was cool if cloudy.
    Bump for the finapimps though

  4. #4
    Buschlightcan's Avatar
    Buschlightcan is offline Associate Member
    Join Date
    Oct 2002
    Location
    Southern California
    Posts
    378
    Yeah i used a filter through the syringe but not a coffe filter. I strictly followed the gotfina outline..

  5. #5
    Vaj10's Avatar
    Vaj10 is offline Associate Member
    Join Date
    May 2002
    Location
    Northern New Jersey
    Posts
    323
    Originally posted by painintheazz
    The batch that I just mad came out a little cloudy. It is still working fine for me. I think it is due to the extra heating that you did. I heated mine a little extra to make sure everything was dissolved nicely. IMO I think you are fine. You did use a filter, right????? I will leave it up to a more knowledgable fina bro to give a final answer.

    Pain
    i agree... mines a lil cloudy but works fine for me... check out my pic its a little cloudy...
    http://anabolicreview.com/vbulletin/...threadid=40544

  6. #6
    painintheazz's Avatar
    painintheazz is offline Anabolic Member
    Join Date
    Dec 2002
    Location
    Boston area
    Posts
    3,352
    Mine looks exactly like yours Vaj.

  7. #7
    Buschlightcan's Avatar
    Buschlightcan is offline Associate Member
    Join Date
    Oct 2002
    Location
    Southern California
    Posts
    378
    Mine looks a tad bit cloudier but im glad to know that your guys looks pretty close and it still works.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •