Anabolics
Search More Than 6,000,000 Posts
Results 1 to 11 of 11

Thread: test problem

  1. #1
    btrain is offline Junior Member
    Join Date
    Jan 2003
    Location
    Missouri
    Posts
    55

    test problem

    ok I just started my cycle and Ive done 2 tricep shots and each time my tricep swelled up and the back of my arms are red. my tricep is hard in the area I shot.My friend also shot in his shoulder and the same thing happened. what should I do ive done test before did I possible get a bad batch. It is qv test 250 if that helps. should I still use it or not.any info will help. thanks

  2. #2
    956Vette is offline AR-Elite Hall of Famer
    Join Date
    Mar 2003
    Location
    United States
    Posts
    10,154
    Blog Entries
    1
    Are you sterilizing everything?

  3. #3
    NoLimits's Avatar
    NoLimits is offline Member
    Join Date
    Feb 2002
    Location
    California
    Posts
    809
    It could be your body’s response to the BA content. If you are both using alcohol and wiping the area clean prior to injecting, and using clean, new pins each time, that is the only explanation I can think of. Were there seals on the top of the bottles of the Qv?

  4. #4
    WiLLpOwEr's Avatar
    WiLLpOwEr is offline Member
    Join Date
    May 2003
    Location
    Living my life to the fullest!
    Posts
    553
    Possibly injecting too fast?

  5. #5
    symatech's Avatar
    symatech is offline Retired Moderator
    Join Date
    May 2002
    Location
    not where I want to be
    Posts
    7,546
    you should also rotate injection spots. are you sure your gear is legit? If the problem persists for a while Id go see the doctor. But first wait a few days to see if the problem dies down.

  6. #6
    ItalianMuscle27 is offline Senior Member
    Join Date
    Apr 2003
    Location
    Italy
    Posts
    1,414
    Usually if I shoot to fast I get a little knot! I personally wouldnt use test for site injections. Save the site injects for winny!

  7. #7
    btrain is offline Junior Member
    Join Date
    Jan 2003
    Location
    Missouri
    Posts
    55
    I know for a fact the gear is legit. I did both my left and right tricep. My friend has the same problem but in his shoulder. All the gear has the caps. I use a 25g 5/8 needle I have done well over 100 injections between me and my friends. but I never had this happen before should I use a different bottle and see if this happens.thanks

  8. #8
    WiLLpOwEr's Avatar
    WiLLpOwEr is offline Member
    Join Date
    May 2003
    Location
    Living my life to the fullest!
    Posts
    553
    If you've done over 100 injections, I think you know what you are doing, so I think it's a bad batch of gear. Ya, I think you should use another bottle and see what happens.

    If problem persists see a doctor.

  9. #9
    mountiebenchmonster is offline Junior Member
    Join Date
    Apr 2003
    Location
    canada
    Posts
    98
    Do you really think you should be dishing out important advice Willpower?

    I mean your as much of a novice as I am and I dont think either of us are qualified to advise people with way more experience than us.

  10. #10
    btrain is offline Junior Member
    Join Date
    Jan 2003
    Location
    Missouri
    Posts
    55
    I am going to try a different bottle. Ill let you know how it goes thanks.

  11. #11
    btrain is offline Junior Member
    Join Date
    Jan 2003
    Location
    Missouri
    Posts
    55
    I am getting a different batch and ill see how that goes thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •