Results 1 to 4 of 4
  1. #1
    m16a2 is offline Senior Member
    Join Date
    Aug 2002
    Location
    LA
    Posts
    1,523

    no injection-site blood?

    Since last week, I do my injection into the glutes and there hasn't been one drop of post-injection blood. I don't understand why it would just disappear week 6. Does anyone else not have any blood at all when they inject? I just think its weird that I can push that needle almost 1.5 inches into my body and not see any blood from the site.

    Is it possible that I'm shooting in the wrong spot? I aspirate , and its always air, so I know im not hitting a vessel.

  2. #2
    m16a2 is offline Senior Member
    Join Date
    Aug 2002
    Location
    LA
    Posts
    1,523
    that's kinda funny because i really have no idea what I'm doing when I go in there. I guess I'll just keep doing whats working. I was just kinda worried that maybe I was doing something wrong. It's a tough angle when you do self-injects, especially in the left

  3. #3
    trimunex's Avatar
    trimunex is offline Senior Member
    Join Date
    Jul 2002
    Location
    SoCal
    Posts
    1,118
    Same thing here Bro, I rarely have any blood appear after a glute inject. Like Enrage said, you did it the right way and found a good spot.

    9

  4. #4
    durbin22's Avatar
    durbin22 is offline Member
    Join Date
    May 2002
    Location
    North of Boston
    Posts
    525
    The same thing happened to me last night doing delts. I usually bleed when doing quads but for some reason there's no blood with delts.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •