Results 1 to 9 of 9
  1. #1
    Josh1 is offline New Member
    Join Date
    May 2017
    Posts
    4

    Post First cycle - Swelling, Redness, Pain

    hey everyone,

    Im on my first cycle of test E - running it twice a week. Ive jabbed 3 times now, Right quad, Left and right glue.
    A day after injecting into my glute, it swelled up heaps and has gone a bit red. But the worst part is the pain, that bad that I cant sleep on it, sit on it or even walk without pain. Its almost been a week and it haste subsided at all. Im thinking I didn't inject deep enough and now the oil based liquid is just sitting there outside the muscle. It has also shifted a bit into my upper thigh and can see the lump very well. Ive tried icing, heat packs, hot baths and even anti inflammatory to help but nothing.
    Im using a 23g 1 1/4 needle and doing everything I can safety wise to make sure its all sterile. Has anyone has any experience with this or know whats happening?
    Cheers in advance

  2. #2
    DocToxin8's Avatar
    DocToxin8 is offline Knowledgeable Member
    Join Date
    May 2015
    Location
    Land of the screwed
    Posts
    2,157
    If it's too close to the skin then this might happen,
    but it should have subsided within a week, or 3-5 days.

    This is your first cycle so your muscles might be more sore now than later,
    but this still doesn't sound quite right.

    What concentration is the gear?
    Is it a UGL?

  3. #3
    Chicagotarsier is offline Senior Member
    Join Date
    Mar 2014
    Location
    Asia but not Asian.
    Posts
    1,560
    Be truthful. Did you alcohol swab before pinning? This has happened once to me and it was the one time I did not clean beforehand. I had to use antibiotics to get rid of my instance.

  4. #4
    Josh1 is offline New Member
    Join Date
    May 2017
    Posts
    4
    Its slowly subsiding with massage to the area.... Im taking Test E 250mg and injecting 1.25ml twice a week.

  5. #5
    Josh1 is offline New Member
    Join Date
    May 2017
    Posts
    4
    100% being as clean as I can. I swab the top of the vial, the site, drawing needle then injecting needle then the site again... I'm heading to the doctors tomorrow for them to check it out - hopefully nothing too bad...
    What injection site would you recommend then? snd should I be doing IM or SC injections?
    Cheers

  6. #6
    charger69's Avatar
    charger69 is offline Knowledgeable Member
    Join Date
    Apr 2015
    Location
    SoCal
    Posts
    4,377
    You might want to use 25 gage to inject. It did make a difference with me. Never had the area red.
    I also would not wipe the needle, it should already be sterile.
    If all areas are red and they do not go down within 3-5 days i would suspect the AAS.

  7. #7
    PT1982's Avatar
    PT1982 is offline Knowledgeable Member
    Join Date
    Feb 2017
    Location
    Home of the Braves
    Posts
    1,504
    Don't swab the needle. You're actually taking a bigger risk in contaminating it. It is already sterile, so leave it alone. Swab the site and the vial top and you'll be good. I doubt you have an infection. Sometimes of the gear doesn't get deep into the muscle, you can get what I call oil leak/travel. The oil will actually ruin down under the skin a little. The body will still absorb it, it just takes a little longer. What I'm getting at, when it does this, it can lead to mild cellulitis, which can be very painful and hot to the touch. Often times a few days off antibiotics will clear it right up, but try not to use antibiotics of you can help it. Abcess and infection isn't really common, but many people just assume they have an infection. I think it's our nature sometimes to assume the worst case scenario. I'd say you're ok buddy. Just keep a check on it. Good luck and get better!

  8. #8
    AR's King Silabolin's Avatar
    AR's King Silabolin is offline Castle Power
    Join Date
    May 2015
    Location
    Norway
    Posts
    4,588
    Quote Originally Posted by Chicagotarsier View Post
    Be truthful. Did you alcohol swab before pinning? This has happened once to me and it was the one time I did not clean beforehand. I had to use antibiotics to get rid of my instance.
    I never cleaned with anything. Always gtg. But i use 1,5 inch for oilbased. I think this migth be the reason he got problemes.

  9. #9
    Josh1 is offline New Member
    Join Date
    May 2017
    Posts
    4
    Thanks bro, I really appreciate it. Where abouts do you inject? what would you recomend ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •